Linux on Fujitsu-Siemens Amilo A7600


Current distro:  Ubuntu 6.06 (Dapper Drake)

What works:

Display Works, must disable dri
Sound Works out of the box
USB Works, outer plug OK. The other two only usable if the option irqpoll is given as a boot parameter
PCMCIA Works out of the box
Firewire Not tested
Hibernate Partly works, sometimes system hangs on wakeup.
CD Works out of the box, read and write
Buttons Works out of the box (has Browser and Email buttons)
Ethernet Works out of the box

Additional comments:

The output of lspci:

0000:00:00.0 Host bridge: ATI Technologies Inc AGP Bridge [IGP 320M] (rev 13)
0000:00:01.0 PCI bridge: ATI Technologies Inc PCI Bridge [IGP 320M] (rev 01)
0000:00:02.0 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
0000:00:03.0 Modem: ALi Corporation M5457 AC'97 Modem Controller
0000:00:04.0 IDE interface: ALi Corporation M5229 IDE (rev c4)
0000:00:06.0 Bridge: ALi Corporation M7101 Power Management Controller [PMU]
0000:00:07.0 ISA bridge: ALi Corporation M1533 PCI to ISA Bridge [Aladdin IV]
0000:00:08.0 Multimedia audio controller: ALi Corporation M5451 PCI AC-Link Controller Audio Device (rev 02)
0000:00:09.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
0000:00:0a.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev 46)
0000:00:0b.0 CardBus bridge: ENE Technology Inc CB1420 Cardbus Controller (rev 01)
0000:00:0b.1 CardBus bridge: ENE Technology Inc CB1420 Cardbus Controller (rev 01)
0000:00:0f.0 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
0000:01:05.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility U1
0000:02:00.0 Network controller: Texas Instruments ACX 100 22Mbps Wireless Interface

Installation:

After the installation, booting first commences OK, but the system hangs when starting the X windows system. The culprit is the apparently buggy ATI controller. I commented out the dri module from /etc/X11/xorg.conf after which the display works. No direct rendering, but I am no player so I really don't care.

Wireless:

I also have D-Link DWL-650+ wireless PCMCIA card. This used to be a PITA, but fortunately the current kernel 2.6.15-26-386 correctly recognizes the card and loads the acx module.  (Using Ubuntu 5.10 I had to resort to additional wlan packages).
TuxMobil - Linux on Laptops, Notebooks, PDAs and Mobile Phones